Friday, January 5, 2018

Anaconda + Gromacs (with GPU and Cuda) Installation = Problems!!!

It has been a while since I have posted.
This will be a very short post.

If you plan to use GROMACS with GPU support and Anaconda Python Distribution, it is much better to install GROMACS first then Anaconda.
If you try to install GROMACS after installing Anaconda, you will receive compilation errors (Particularly GCC errors).
The easiest way to fix on Linux ( in my case Ubuntu 16.04) is to comment line of Anaconda (.bashrc file). Compile and install GROMACS  with GPU support and then uncomment.
Or just install GROMACS first then Anaconda.













Hope this helps. 

No comments:

Post a Comment